找回密码
 骑士注册

QQ登录

微博登录

搜索
❏ 站外平台:

Linux中国开源社区 技术 查看内容

Debian 7.0 常见问题的处理方法

2013-05-24 09:43    评论: 3    

  随着社区Linux版本Debian7.0.0稳定版的发布,笔者也和很多Linux系统的爱好者一样,进行了下载以及安装使用。现就存在的一些小问题及解决办法进行整理编辑,希望能帮助更多的Linux爱好者们一同感受Linux操作系统带来的稳定以及魅力。

https://dn-linuxcn.qbox.me/data/attachment/album/201305/23/122831c3x2gxfjrg2cw8c1.jpg

1、时区设置问题

  Debian 7.0 在安装时尽管选择了中国时区以及非UTC时钟,但机器安装好启动后时间还是会发生错误,因此需要进行将时钟调整为当前时间,同时需要修改文件/etc/default/rcS,并在该文件中加入UTC=no参数。

2、普通用户使用KVM报错问题

  Debian 7.0 中普通用户使用virt-manager虚拟系统管理器时会报错,但切换到root用户又可以正常使用。其实这个问题是用户权限的问 题,virt-manager虚拟系统管理器需要libvirt组用户才可以正常使用和管理,因此用户只要执行useradd -g libvirt birdofprey 命令就可以正常使用该虚拟机管理工具了。

  命令模式如下:

useradd -g libvirt birdofprey

  其中birdofprey为需要使用virt-manager虚拟系统管理器工具的用户名。

3、在KVM中客户机使用NAT方式联网无法正常进行PPTP拨号以及FTP问题

  在KVM中客户机之前使用桥模式进行网络连接,PPTP拨号及FTP都没有问题,修改为NAT模式之后,KVM客户机使用PPTP拨号出现619错 误,访问FTP服务器也出现无法登录500错误。该问题存在的原因是因为PPTP方式的VPN使用了GRE协议,这个协议跟TCP/UDP是同一级的协 议。因为GRE协议没有端口的概念,LINUX不能像TCP/UDP那样IP伪装。所以,LINUX网关后面的pptp vpn客户机连接vpn时总会遇见这种那种的问题。也就是所谓pptp pass through  PPTP VPN协议 NAT穿透性问题!,解决该问题需要对Debian7的/etc/modules文件进行修改加入如下行内容:

    ip_nat_pptp
    ip_conntrack_pptp
    ip_conntrack_ftp
    ip_nat_ftp

  这样iptables在每次启动的时候都自动加载以上4个NAT穿透功能模块。再次在KVM客户机中以NAT模式网络进行相关的PPTP拨号及FTP访问时早先存在的619及500错误得到解决。

4、GNOME3任务栏、标题栏过宽问题

  Debian 7.0 默认安装的是GNOME 3.4.2桌面系统,缺省状态下,用户会发现桌面系统的桌面任务栏及标题栏宽度太大,影响美观,同时也浪费屏幕显示的有效宽度,针对这个问题我们可以通过以下方式进行优化。

  任务栏优化:

  使用vi /usr/share/gnome-shell/theme/gnome-shell.css,直接找到如下行:

    #panel {
    background-color: black;
    font-weight: bold;
    height: 1.28em;
    }

  将原来的height:1.68em;修改为height:1.28em;按ALT+F2输入r,直接从起桌面应该就很好看了。

  标题栏的优化:

  在终端中直接输入如下内容:

    sed -i "/title_vertical_pad/s/value=\"[0-9]\{1,2\}\"/value=\"0\"/g" /usr/share/themes/Adwaita/metacity-1/metacity-theme-3.xml

  之后按ALT+F2输入r,直接从起桌面应该就好了。

5、安装GNOME-SHELL插件netspeed、Coverflow Alt-Tab网站报You do not appear to have an up to date version of GNOME3. You won't be able to install extensions from here. See the about pagefor more information.错误问题。

  GNOME-SHELL作为GNOME3桌面系统的重要特性之一,给用户带来了很多不一样的感受和体验,其插件安装在3.6以后非常方便,只需要通过网页登录到网站将相应插件的相应开关打开到ON的位置,那么系统将自动为你在本地系统中创建插件功能。但在Debian 7.0 中,因为GNOME版本为GNOME3.4.2,通过网页访问网站时, 网站会报如下提示You do not appear to have an up to date version of GNOME3. You won't be able to install extensions from here. See the about pagefor more information。因此安装以上两个插件包需要进行手动安装。

  首先在https://github.com/hedayaty/NetSpeed、https://github.com/dmo60 /CoverflowAltTab下载相关软件组建的ZIP包,将他们解压在用户的.local/share/gnome-shell /extensions/ 目录中,并将文件目录设置为XXX@XXX.XX模式,然后用tweak tool开启就行了。

来自:http://os.51cto.com/art/201305/395213.htm

最新评论

我也要发表评论

绿色圣光 2013-05-23 12:39 回复

我最终还是没有升级到7.0

7.0的各个组件版本对我而言,挺尴尬的。新的不够新,老的不够老。

微博评论 2013-05-23 15:37 回复
mark  就是太麻烦

来自 woisunny 的新浪微博
愉欣 2013-05-24 16:34 回复

我没发现时区设置有啥问题,我这相当正常。

收藏

返回顶部

分享到微信

打开微信,点击顶部的“╋”,
使用“扫一扫”将网页分享至微信。