找回密码
 骑士注册

QQ登录

微博登录

搜索
❏ 站外平台:

Linux中国开源社区 新闻 查看内容

Python 2.7支持时间延长到2020年

2014-04-15 14:05    评论: 13 分享: 7    

Python语言作者Guido van Rossum宣布Python 2.7支持时间延长到2020年。

Python 2.7是2.x系列的最后一个版本,它的继承者Python 3.0在2008年12月发布,但不兼容2.x系列,3.0的许多特性和语法向后移植到了2.6和2.7。Python 2.7的最新版本是2.7.6,2.7.7计划在2014年5月发布,2.7.8计划在2014年11月发布,2.7.9则是在2015年5月,之后将根据需要释出新版本,2.7的支持时间将最少为10年,2020年前会一直提供bug修正。

via: http://www.solidot.org/story?sid=39122

最新评论

我也要发表评论

Tom_Bu 2014-04-17 14:35  新浪微博网友评论 回复
用的我想死//@小白在安同:洗发水 //@Tom_Bu: 继续py2 py3默认的发行版不多吧//@小白在安同:OS3 我认为应当 Py 3.4 基准了 //@某冰磷的碳核: 感人至深 @小白在安同 以后我们用哪个呢?
小白在安同 2014-04-17 12:49  新浪微博网友评论 回复
洗发水 //@Tom_Bu: 继续py2 py3默认的发行版不多吧//@小白在安同:OS3 我认为应当 Py 3.4 基准了 //@某冰磷的碳核: 感人至深 @小白在安同 以后我们用哪个呢?
Tom_Bu 2014-04-17 12:49  新浪微博网友评论 回复
继续py2 py3默认的发行版不多吧//@小白在安同:OS3 我认为应当 Py 3.4 基准了 //@某冰磷的碳核: 感人至深 @小白在安同 以后我们用哪个呢?
小白在安同 2014-04-17 11:16  新浪微博网友评论 回复
OS3 我认为应当 Py 3.4 基准了 //@某冰磷的碳核: 感人至深 @小白在安同 以后我们用哪个呢?
windnestlinux 2014-04-16 10:28 回复
坏消息?呵呵,楼上看过谁在用java8了吗?或者java7?越新就越好?
john1king 2014-04-16 10:16  新浪微博网友评论 回复
历史负担太重了,对py3普及非常不利啊
soli 2014-04-16 09:47 回复
这绝对是个坏消息。

就像微软宣布延长支持 WinXP 一样。
夜域诡士 2014-04-15 20:42 回复
好消息,也是坏消息
某冰磷的碳核 2014-04-15 17:55  新浪微博网友评论 回复
感人至深 @小白在安同 以后我们用哪个呢?
罗源居士 2014-04-15 17:55  新浪微博网友评论 回复
牛气
Mr_Sparetire 2014-04-15 17:55  新浪微博网友评论 回复
卧槽。。那还是果断入坑2.7吧
python爱好者 2014-04-15 14:35  新浪微博网友评论 回复
好消息!
shanlinzi 2014-04-15 14:35  新浪微博网友评论 回复
选2.x还是选3.x,这是个值得思考的问题

收藏

返回顶部

分享到微信

打开微信,点击顶部的“╋”,
使用“扫一扫”将网页分享至微信。