Linux.中国 - 开源社区

 找回密码
 骑士注册

QQ登录

微博登录


Linux 有问必答:如何修复“hda-duplex not supported in this QEMU binary”

2014-11-25 22:30    评论: 2 分享: 2    

提问: 当我尝试在虚拟机中安装一个新的Linux时,虚拟机不能启动且报了下面这个错误:"unsupported configuration: hda-duplex not supported in this QEMU binary."(“不支持的配置:hda-duplex在此QEMU文件中不支持。”) 我该如何修复?

这个错误可能来自一个当默认声卡型号不能被识别时的一个qemu bug。

无法完成安装:‘不支持的配置:hda-duplex在此QEMU文件中不支持’

要解决这个问题,按照下面的做。

方案一: virt-manager

virt-manager中,打开虚拟机的虚拟硬件详细菜单,进入声卡选项,改变默认的设备型号为ac97。

点击“应用”按钮并保存设置。看一下虚拟机现在是否可以启动了。

方案二: Virsh

如果你使用的是virsh 而不是virt-manager, 你可以编辑VM相应的配置文件。在节点中查找sound节点,并按照下面的默认声卡型号改成ac97

<devices>
  . . .
  <sound model='ac97'>
    <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
  </sound>
  . . .
</device>

via: http://ask.xmodulo.com/hda-duplex-not-supported-in-this-qemu-binary.html

译者:geekpi 校对:wxy

本文由 LCTT 原创翻译,Linux中国 荣誉推出

发表评论


最新评论

我也要发表评论

陈_程序员 2014-11-26 16:33  新浪微博网友评论
[思考]
回复
翠西略飞 2014-11-26 00:03  新浪微博网友评论
回答:我不用虚拟机
回复
返回顶部

分享到微信朋友圈

打开微信,点击底部的“发现”,
使用“扫一扫”将网页分享至朋友圈。