找回密码
 骑士注册

QQ登录

微博登录

搜索
❏ 站外平台:

Linux中国开源社区 观点 查看内容

Linus Torvalds 说针对性的模糊测试正提升 Linux 安全性

Linux 4.14 发布候选第五版已经出来。Linus Torvalds 说:“可以去测试了。”

随着宣布推出 Linux 内核 4.14 的第五个候选版本,Linus Torvalds 表示模糊测试fuzzing正产生一系列稳定的安全更新。

模糊测试通过产生随机代码来引发错误来对系统进行压力测试,从而有助于识别潜在的安全漏洞。模糊测试可以帮助软件开发人员在向用户发布软件之前捕获错误。

Google 使用各种模糊测试工具来查找它及其它供应商软件中的错误。微软推出了 Project Springfield 模糊测试服务,它能让企业客户测试自己的软件。

正如 Torvalds 指出的那样,Linux 内核开发人员从一开始就一直在使用模糊测试流程,例如 1991 年发布的工具 “crashme”,它在近 20 年后被 Google 安全研究员 Tavis Ormandy 用来测试在虚拟机中处理不受信任的数据时,宿主机是否受到良好保护。

Torvalds :“另外值得一提的是人们做了多少随机化模糊测试,而且这正在发现东西。”

“我们一直在做模糊测试(谁还记得只是生成随机代码,并跳转过去的老 “crashme” 程序?我们过去很早就这样做),人们在驱动子系统等方面做了一些很好的针对性模糊测试,而且已经有了各种各样的修复(不仅仅是上周的这些)。很高兴可以看到。”

Torvalds 提到,到目前为止,4.14 的发展“比预想的要麻烦一些”,但现在已经好了,并且在这个版本已经跑通了一些针对 x86 系统以及 AMD 芯片系统的修复。还有几个驱动程序、核心内核组件和工具的更新。

如前所述,Linux 4.14 是 2017 年的长期稳定版本,迄今为止,它引入了核心内存管理功能、设备驱动程序更新以及文档、架构、文件系统、网络和工具的修改。


via: http://www.zdnet.com/article/linus-torvalds-says-targeted-fuzzing-is-improving-linux-security/

作者:Liam Tung 译者:geekpi 校对:wxy

本文由 LCTT 原创编译,Linux中国 荣誉推出

最新评论

我也要发表评论

LCTT 译者

geekpi 💎 💎
共计翻译: 587 篇 | 共计贡献: 1488
贡献时间:2013-10-25 -> 2017-11-21
访问我的 LCTT 主页 | 在 GitHub 上关注我

收藏

返回顶部

分享到微信

打开微信,点击顶部的“╋”,
使用“扫一扫”将网页分享至微信。