Linux.中国 - 开源社区

 找回密码
 骑士注册

QQ登录

微博登录


tag 标签:
  • Shellshock [4]


相关文章

Shellshock后续漏洞
CVE-2014-6277和CVE-2014-6278终于曝光。 POC: bash -c "f() { x() { _; }; x() { _; } a; }" 漏洞的发现者Michal Zalewski给出了详细的分析,BASH社区补丁还在紧急的修复中,因为涉及backporting中的一些比较蛋疼的问题,预计UPSTREAM得到这个礼拜末才能完成修复工作。也就是说GNU/Linux发行版最早应该会在本周末或者下个礼拜才能修复,在这一段时期特别对于生产环境的服务器是比较危险的。 有2个方法来降低风险: ASLR/PIE/NX/CANARY/RELRO加固Bash重新部署 保证你的机器至少使用了Florian Weimer的补丁。
2014-10-2 17:43
检查你的系统系统是否有“Shellshock”漏洞并修复它
快速地向你展示如何检查你的系统是否受到Shellshock的影响,如果有,怎样修复你的系统免于被Bash漏洞利用。 如果你正跟踪新闻,你可能已经听说过在Bash中发现了一个漏洞,这被称为Bash Bug或者** Shellshock**。 红帽是第一个发现这个漏洞的机构。Shellshock错误允许攻击者注入自己的代码,从而使系统开放各给种恶意软件和远程攻击。事实上,黑客已经利用它来启动DDoS攻击。 由于Bash在所有的类Unix系统中都有,如果这些都运行bash的特定版本,它会让所有的Linux系统都容易受到这种Shellshock错误的影响。 想知道如果你的Linux系统是否已
2014-10-6 22:08
Linux有问必答:如何检测并修复bash中的破壳漏洞​​
问题:我想要知道我的Linux服务器是否存在bash破壳漏洞,以及如何来保护我的Linux服务器不受破壳漏洞侵袭。 2014年9月24日,一位名叫斯特凡沙泽拉的安全研究者发现了一个名为破壳(Shellshock,也称为bash门或Bash漏洞)的bash漏洞。该漏洞如果被渗透,远程攻击者就可以在调用shell前通过在特别精心编制的环境中输出函数定义执行任何程序代码。然后,这些函数内的代码就可以在调用bash时立即执行。 注意,破壳漏洞影响到bash版本1.14到4.3(当前版本)。虽然在写本文时还没有该漏洞权威而完整的修复方案,也尽管主要的Linux发行版(Debi
2014-10-23 07:01
2014年最危险的五大软件漏洞
安全业界的研究员们每天都在寻找新的软件漏洞,但是已经很久没有象2014年这样出现数量如此之多或影响范围如此之广的漏洞了。回顾即将结束的2014年,一个又一个重量级漏洞接踵而至,受到影响的设备竟以百万计,系统管理员和用户简直要抓狂了。 今年被发现的几个重大安全漏洞震惊了整个互联网,令安全社区颜面尽失,因为这些漏洞并不是在新软件中被发现的,而是从已经推出了几年甚至几十年的老软件中被挖出来的。有几个漏洞可以说是普通用户的悲剧,因为这么多人使用了这么久的时间,人们一直以为它们是没有漏洞的。 SR Labs的柏林安全研究
2014-12-31 08:43
返回顶部

分享到微信朋友圈

打开微信,点击底部的“发现”,
使用“扫一扫”将网页分享至朋友圈。