搜索
❏ 站外平台:

末日即将来到,T-800 终结者内核版本 Linux 4.1.15 出现!

译者: LCTT Xingyu.Wang

| 2015-12-16 11:55   评论: 21    

这或许是一个神奇的巧合,也许是预言。

如果你相信《终结者》电影中情节,那么我们很快就会看到世界末日了 :D 。 看起来,天网所控制的 T-800 机器人运行的是 Linux 内核 4.x,而 Linus Torvalds 先生刚刚释放了最新的 4.1.15内核——这正是电影中说的,T-800 机器人的内核版本。

Linus Torvalds 前一段时间说,他考虑启动 Linux 内核 4.x 版本,而不是发布 3.20 版本,因为他不想再看到像 2.6.32.x 这样啰嗦的版本号了。当时他还没有下定决心,于是在 Google+ 上发起了投票,看看人们的选择。

当然,你现在已经知道了最后的投票结果和最终的决定了,Linux 内核走上了 4.x 分支。他说,他计划让 4.x 分支成为一个稳定的分支,因此要求开发者们专注于修复而不是添加新功能。

而在另一方面,终结者 T-800 运行的版本是 4.1.15,所以,Linus Torvalds 做出了一个非常“艰难的决定”,世界末日就靠它了:D。

终结者当然应该运行 Linux 啦

如果天网Skynet真的那么无所不在,那么它显然应该是基于 Linux 的,同样,终结者Terminator这样的半机器人cyborg显然也应该是基于 Linux。你总不会想让这些终结者在攻击人类最后一个基地的时候出现蓝屏或者升级时崩溃吧?

一个用户在 Reddit 上贴了一张来自《终结者》电影的截屏(不清楚具体来自哪里),可以看到阿诺德 · 施瓦辛格Arnold Schwarzenegger所饰演的 T-800 半机器人运行的正是 Linux 内核 4.1.15,具体内核型号:Linux 4.1.15-1.1381_SKYN12nnmp(slawes.sky.net)。这可是不是你炕头上的那台老式计算机,而是天网版的!

那么问题来了:如果 Linus Torvalds 还在不断的发布内核更新,天网会升级它的系统吗?会让它的半机器人使用这个采用 GPL 许可证的 OS 吗——这可是要开源出来的。

LCTT 译者
共计翻译: 233.0 篇 | 共计贡献: 1549
贡献时间:2014-07-25 -> 2018-10-21
访问我的 LCTT 主页 | 在 GitHub 上关注我


返回顶部

分享到微信

打开微信,点击顶部的“╋”,
使用“扫一扫”将网页分享至微信。