Linux.中国 - 开源社区

 找回密码
 骑士注册

QQ登录

微博登录


Debian 升级到 PHP 7,并支持并行安装

2016-1-20 10:27    收藏: 1    

Debian 开发者 Ondřej Surý 前几天在一个邮件列表中宣布他们开始迁移到 PHP 7.x 了,并支持多版本并行安装co-installable。而此前几天,Ubuntu 也宣布其下一个版本 16.04 Xenial Xerus 将迁移到 PHP 7.x 。

Ondřej Surý 说:“如果你感兴趣这方面的讨论,推荐你加入到 pkg-php-maint, pkg-php-pecl 以及 pkg-php-pear 邮件列表,我们会在这里深入讨论。”

当前,PHP 7 已经出现在了 Debian Unstable 当中。想要帮助测试的人可以使用该分支进行测试了。

这次升级到 PHP 7 的一些值得注意的细节有:

  1. 软件包的名字将变成 phpMAJOR.MINOR 格式,包含了子版本号,即从原来的 php5-fpm 变成了 php7.0-fpm。
  2. 软件包会指向到默认的版本包,比如 php-fpm 会指向到 php7.0-fpm。除非特别需要,否则应该使用 php-fpm 包名。
  3. 相应的,路径也都变成带有小版本号的名称了,如:/etc/php5/cli 现在是 /etc/php/7.0/cli 。
  4. php-pear 现在不从独立源代码中构建了。
  5. PHP 7.0 改变了扩展 API,所以基本上全部的扩展都需要上游完成 PHP 7.0 兼容性修改。
  6. 预期在下一个 Debian 发行版(stretch)中只装载 PHP 7.0,也就是说到那时需要所有的扩展包都兼容 PHP 7.0。大多数扩展包都处于良好维护中,因此这不是问题。然而有一些废弃的包(比如 mysql)和不再维护的包就没法工作了,会从稳定版的 Debian 中移去。
  7. 当前的 Unstable 通道支持并行安装,即 php5 和 php7.0 会并存,所以改变很小,系统管理员可以有机会慢慢修正其配置。

参考:debiansoftpedia

发表评论


最新评论

我也要发表评论

返回顶部

分享到微信朋友圈

打开微信,点击底部的“发现”,
使用“扫一扫”将网页分享至朋友圈。