骑士注册 登录
Linux 中国◆开源社区 返回首页

LinuxSQL的个人空间 https://linux.cn/space/16475 [收藏] [复制] [分享] [RSS]

日志

Zabbix安装前传之安装依赖包错误解决

已有 2144 次阅读2014-12-09 17:53 |个人分类:Linux服务安装

Hello,大家好:
我是——邪恶君子!今天呢,给大家解决一下,在安装zabbix时,可能会在第一步就报错,那就是安装环境依赖包,首先,安装的都哪些东西呢,先给大家罗列出来:
yum -y install gcc gcc-c++ autoconf httpd php mysql mysql-server php-mysql httpd-manual mod_ssl mod_perl mod_auth_mysql php-gd php-xml php-mbstring php-ldap php-pear php-xmlrpc php-bcmath mysql-connector-odbc mysql-devel libdbi-dbd-mysql net-snmp-devel curl-devel unixODBC-devel OpenIPMI-devel java-devel
大家已经看出来啦,红色标记的就是容易报出的安装包,要么说找不到,没有这些包,要么就是在yum安装时报出各种Error,说无法下载。
那,这种问题到底怎么解决呢,很简单,下面给你操作过程,保准你掌握,看招吧:
[root@localhost ~]# rpm -ivh http://vault.centos.org/6.5/os/x86_64/Packages/php-bcmath-5.3.3-26.el6.x86_64.rpm
 
[root@localhost ~]# rpm -ivh http://vault.centos.org/6.5/os/x86_64/Packages/php-mbstring-5.3.3-26.el6.x86_64.rpm
[root@localhost ~]# rpm -ivh http://vault.centos.org/6.5/os/x86_64/Packages/OpenIPMI-libs-2.0.16-14.el6.x86_64.rpm
[root@localhost ~]# rpm -ivh http://vault.centos.org/6.5/os/x86_64/Packages/OpenIPMI-python-2.0.16-14.el6.x86_64.rpm
[root@localhost ~]# rpm -ivh http://vault.centos.org/6.5/os/x86_64/Packages/OpenIPMI-perl-2.0.16-14.el6.x86_64.rpm 
[root@localhost ~]# rpm -ivh http://vault.centos.org/6.5/os/x86_64/Packages/OpenIPMI-2.0.16-14.el6.x86_64.rpm 
[root@localhost ~]# rpm -ivh http://vault.centos.org/6.5/os/x86_64/Packages/OpenIPMI-devel-2.0.16-14.el6.x86_64.rpm
注意:一定要按照顺序来哦,否则会报依赖关系的错误

到此,所有安装问题基本上就解决了,如果还有其他问题,可以留言交流一下!
其它参考:http://linux.cn/blog-16475-5875.html

 已同步至 LinuxSQL的微博

返回顶部

分享到微信

打开微信,点击顶部的“╋”,
使用“扫一扫”将网页分享至微信。