搜索
❏ 站外平台:

Unity 编辑器现已正式面向 Linux 推出

作者: Ankush Das 译者: LCTT geekpi

| 2019-06-14 11:21      

如果你是设计师、开发者或艺术家,你可能一直在使用 Linux 上的实验性 Unity 编辑器。然而,不能一直用实验性版本 —— 开发者需要一个完整稳定的工作经验。

因此,他们最近宣布你可以在 Linux 上使用完整功能的 Unity 编辑器了。

虽然这是一个令人兴奋的消息,但它正式支持哪些 Linux 发行版?我们来谈谈更多细节……

非 FOSS 警告

Linux (或任何其他平台)上的 Unity 编辑器不是开源软件。我们在这里介绍它是因为:

官方支持 Ubuntu 和 CentOS 7

无论你拥有个人许可还是专业许可,如果你安装了 Unity 2019.1 或更高版本,都可以使用该编辑器。

此外,他们优先支持 Ubuntu 16.04、Ubuntu 18.04 和 CentOS 7。

公告中,他们还提到了支持的配置:

  • x86-64 架构
  • 运行在 X11 窗口系统之上的 Gnome 桌面环境
  • Nvidia 官方专有显卡驱动和 AMD Mesa 显卡驱动
  • 桌面计算机,在没有仿真或兼容层的设备/硬件上运行

你可以尝试其他的 —— 但最好坚持官方要求以获得最佳体验。

关于第三方工具的说明

如果你碰巧在某个项目中使用了任何第三方工具,那么必须单独检查它们是否支持。

如何在 Linux 上安装 Unity 编辑器

现在你已经了解了,那么该如何安装?

要安装 Unity,你需要下载并安装 Unity Hub

Unity Hub

你需要完成以下步骤:

  • 官方论坛页面下载适用于 Linux 的 Unity Hub。
  • 它将下载一个 AppImage 文件。简单地说,让它可执行并运行它。如果你不了解,你应该查看关于如何在 Linux 上使用 AppImage 的指南。
  • 启动 Unity Hub 后,它会要求你使用 Unity ID 登录(或注册)以激活许可证。有关许可证生效的更多信息,请参阅他们的 FAQ 页面
  • 使用 Unity ID 登录后,进入 “Installs” 选项(如上图所示)并添加所需的版本/组件。

就是这些了。这就是获取并快速安装的最佳方法。

总结

即使这是一个令人兴奋的消息,但官方配置支持似乎并不广泛。如果你在 Linux 上使用它,请在他们的 Linux 论坛帖子上分享你的反馈和意见。

你觉得怎么样?此外,你是使用 Unity Hub 安装它,还是有更好的方法来安装?

请在下面的评论中告诉我们你的想法。


via: https://itsfoss.com/unity-editor-linux/

作者:Ankush Das 选题:lujun9972 译者:geekpi 校对:wxy

本文由 LCTT 原创编译,Linux中国 荣誉推出

订阅“Linux 中国”官方小程序来查看


最新评论

LCTT 译者
geekpi 💎💎💎
共计翻译: 1027.5 篇 | 共计贡献: 2128
贡献时间:2013-10-25 -> 2019-08-23
访问我的 LCTT 主页 | 在 GitHub 上关注我


返回顶部

分享到微信

打开微信,点击顶部的“╋”,
使用“扫一扫”将网页分享至微信。