Linux.中国 - 开源社区

 找回密码
 骑士注册

QQ登录

微博登录


Linux有问必答:如何在CentOS或者RHEL上启用Nux Dextop仓库

2014-9-24 10:59    评论: 5 分享: 1    

问题: 我想要安装一个在Nux Dextop仓库的RPM包。我该如何在CentOS或者RHEL上设置Nux Dextop仓库?

Nux Dextop是一个面对CentOS、RHEL、ScientificLinux的含有许多流行的桌面和多媒体相关的包的第三方RPM仓库(比如:Ardour,Shutter等等)。目前,Nux Dextop桌面对CentOS和RHEL 6/7可用。

要在CentOS或者RHEL上启用Nux Dextop,遵循下面的步骤。

首先,要知道Nux Dextop被设计与EPEL仓库共存。因此,你需要在使用Nux Dexyop仓库前先启用 EPEL

启用EPEL后,用下面的命令安装Nux Dextop仓库。

在 CentOS/RHEL 6.* 上:

$ sudo rpm -Uvh http://li.nux.ro/download/nux/dextop/el6/x86_64/nux-dextop-release-0-2.el6.nux.noarch.rpm

在 CentOS/RHEL 7 上 :

$ sudo rpm -Uvh http://li.nux.ro/download/nux/dextop/el7/x86_64/nux-dextop-release-0-1.el7.nux.noarch.rpm

现在验证Nux Dextop仓库是否已经成功安装:

$ yum repolist 

对于 Repoforge/RPMforge 用户

据作者所说,目前已知Nux Dextop会与其他第三方库比如Repoforge和ATrpms相冲突。因此,如果你启用了除了EPEL的其他第三方库,强烈建议你将Nux Dextop仓库设置成“default off”(默认关闭)状态。就是用文本编辑器打开/etc/yum.repos.d/nux-dextop.repo,并且在nux-desktop下面将"enabled=1" 改成 "enabled=0"。

$ sudo vi /etc/yum.repos.d/nux-dextop.repo 

无论何时当你从Nux Dextop仓库安装包时,显式地用下面的命令启用仓库。

 $ sudo yum --enablerepo=nux-dextop install <package-name> 

via: http://ask.xmodulo.com/enable-nux-dextop-repository-centos-rhel.html

译者:geekpi 校对: wxy

本文由 LCTT 原创翻译,Linux中国 荣誉推出

发表评论


最新评论

我也要发表评论

老沙 2014-9-26 06:48
[点击展开更多楼层]
2
linux 发表于 2014-9-25 15:57 的评论:
为什么不能?
3
老沙 发表于 2014-9-25 16:53 的评论:
目前Centos官方库里面还是5.3.3,所以想问问这个库是否收录了5.3.10以上的版本,有个网站要用到新版
4
linux 发表于 2014-9-25 21:59 的评论:
应该不会包括 PHP 的,我其实建议你直接用源码编译比较好,一般我的习惯是,基础组件用原来的包,应用部分,比如 APACHE、NGINX、PHP 都自己编译。
我也试了一下,确实没有新的PHP,看来还是要自己编译。N多年没有编译安装过了,再回味一下
7 回复
linux 2014-9-25 21:59
1
老沙 发表于 2014-9-25 15:26 的评论:
可以升级6.5上面的php版本吗?
2
linux 发表于 2014-9-25 15:57 的评论:
为什么不能?
3
老沙 发表于 2014-9-25 16:53 的评论:
目前Centos官方库里面还是5.3.3,所以想问问这个库是否收录了5.3.10以上的版本,有个网站要用到新版
应该不会包括 PHP 的,我其实建议你直接用源码编译比较好,一般我的习惯是,基础组件用原来的包,应用部分,比如 APACHE、NGINX、PHP 都自己编译。
回复
老沙 2014-9-25 16:53
1
老沙 发表于 2014-9-25 15:26 的评论:
可以升级6.5上面的php版本吗?
2
linux 发表于 2014-9-25 15:57 的评论:
为什么不能?
目前Centos官方库里面还是5.3.3,所以想问问这个库是否收录了5.3.10以上的版本,有个网站要用到新版
回复
linux 2014-9-25 15:57
1
老沙 发表于 2014-9-25 15:26 的评论:
可以升级6.5上面的php版本吗?
为什么不能?
回复
老沙 2014-9-25 15:26
可以升级6.5上面的php版本吗?
回复

热点评论

老沙 2014-9-26 06:48
我也试了一下,确实没有新的PHP,看来还是要自己编译。N多年没有编译安装过了,再回味一下
7
返回顶部

分享到微信朋友圈

打开微信,点击底部的“发现”,
使用“扫一扫”将网页分享至朋友圈。